Read the docs
TI-2021-22725 Aliases GHSA-qh54-9vc5-m9fg

MD5 hash support in github.com/foxcpp/maddy

Priority LOW 38CWE-261Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
—
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub.

Summary

### Impact This vulnerability affects maddy 0.5.1, 0.5.0 users using auth.shadow module and an extremely outdated system that still allows MD5 hashes in /etc/shadows. ### Patches Patch is available as part of the 0.5.2 release. ### Workarounds Ensure MD5 hashes are not present in /etc/shadow.

Why it matters now

Fix Fixed github.com/foxcpp/maddy (Go): 0.5.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—github.com/foxcpp/maddy (Go)0.5.0 to before 0.5.20.5.2Patch availableGHSA-qh54-9vc5-m9fg
  • github.com/foxcpp/maddy (Go) Vendor— Affected 0.5.0 to before 0.5.2 Fixed in 0.5.2 Patch available GHSA-qh54-9vc5-m9fg

Remediation

  • Fix · GHSA-qh54-9vc5-m9fg github.com/foxcpp/maddy (Go) Fixed in 0.5.2 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-qh54-9vc5-m9fg

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences