Read the docs
TI-2021-22736 Aliases GHSA-jcjx-c3j3-44pr

Insufficient Session Expiration in @cyyynthia/tokenize

Priority LOW 38CWE-613Published · Updated

Key facts

Attack vector
—
Privileges required
—
User interaction
—
Attack complexity
—
Impact type
Security bypass
Confidentiality · integrity · availability
—
Fix status
Fixed

No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-613.

Summary

### Impact A bug introduced in version 1.1.0 made Tokenize generate faulty tokens with NaN as a generation date. As a result, tokens would not properly expire and remain valid regardless of the `lastTokenReset` field. ### Patches Version 1.1.3 contains a patch that'll invalidate these faulty tokens and make new ones behave as expected. ### Workarounds None. Tokens do not hold the necessary information to perform invalidation anymore. ### References PR #1 ### For more information If you have any questions or comments about this advisory: * Open an issue in [github.com/cyyynthia/tokenize](https://github.com/cyyynthia/tokenize) * Email us at [[email protected]](mailto:[email protected])

Why it matters now

Fix Fixed @cyyynthia/tokenize (npm): 1.1.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—@cyyynthia/tokenize (npm)1.1.0 to before 1.1.31.1.3Patch availableGHSA-jcjx-c3j3-44pr
  • @cyyynthia/tokenize (npm) Vendor— Affected 1.1.0 to before 1.1.3 Fixed in 1.1.3 Patch available GHSA-jcjx-c3j3-44pr

Remediation

  • Fix · GHSA-jcjx-c3j3-44pr @cyyynthia/tokenize (npm) Fixed in 1.1.3 Advisory →

Timeline

  1. 2026-10-03 Threatist record created from GHSA-jcjx-c3j3-44pr

References

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences