Ambiguous OCI manifest parsing
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact In the OCI Distribution Specification version 1.0.0 and prior and in the OCI Image Specification version 1.0.1 and prior, manifest and index documents are ambiguous without an accompanying Content-Type HTTP header. Versions of containerd prior to 1.4.12 and 1.5.8 treat the Content-Type header as trusted and deserialize the document according to that header. If the Content-Type header changed between pulls of the same ambiguous document (with the same digest), the document may be interpreted differently, meaning that the digest alone is insufficient to unambiguously identify the content of the image. ### Patches This issue has been fixed in containerd 1.4.12 and 1.5.8. Image pulls for manifests that contain a “manifests” field or indices which contain a “layers” field are rejected. ### Workarounds Ensure you only pull images from trusted sources. ### References https://github.com/opencontainers/distribution-spec/security/advisories/GHSA-mc8v-mgrf-8f4m https://github.com/opencontainers/image-spec/security/advisories/GHSA-77vh-xpmg-72qh ### For more information If you have any questions or comments about this advisory: * Open an issue in [containerd](https://github.com/containerd/containerd/issues/new/choose) * Email us at [[email protected]](mailto:[email protected])
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | github.com/containerd/containerd (Go) | before 1.4.12 | 1.4.12 | Patch available | GHSA-5j5w-g665-5m35 |
| — | github.com/containerd/containerd (Go) | 1.5.0 to before 1.5.8 | 1.5.8 | Patch available | GHSA-5j5w-g665-5m35 |
- github.com/containerd/containerd (Go) Vendor— Affected before 1.4.12 Fixed in 1.4.12 Patch available GHSA-5j5w-g665-5m35
- github.com/containerd/containerd (Go) Vendor— Affected 1.5.0 to before 1.5.8 Fixed in 1.5.8 Patch available GHSA-5j5w-g665-5m35
Remediation
- Fix · GHSA-5j5w-g665-5m35 github.com/containerd/containerd (Go) Fixed in 1.4.12 Advisory →
- Fix · GHSA-5j5w-g665-5m35 github.com/containerd/containerd (Go) Fixed in 1.5.8 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5j5w-g665-5m35
References
Other 8
- https://github.com/containerd/containerd/security/advisories/GHSA-5j5w-g665-5m35
- https://github.com/opencontainers/distribution-spec/security/advisories/GHSA-mc8v-mgrf-8f4m
- https://github.com/opencontainers/image-spec/security/advisories/GHSA-77vh-xpmg-72qh
- https://github.com/containerd/containerd/commit/26c76a3014e71af5ad2f396ec76e0e0ecc8e25a3
- https://github.com/containerd/containerd/commit/db00065a969a983ceb0a409833f93f705f284ea4
- https://github.com/containerd/containerd
- https://github.com/containerd/containerd/releases/tag/v1.4.12
- https://github.com/containerd/containerd/releases/tag/v1.5.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences