Authentication Bypass by CSRF Weakness
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- Tampering
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub. Impact type from CWE-352.
Summary
### Impact The actual vulnerability has been discovered on `solidus_auth_devise`. See [GHSA-xm34-v85h-9pg2](https://github.com/solidusio/solidus_auth_devise/security/advisories/GHSA-xm34-v85h-9pg2) for details. The security advisory here exists to provide an extra layer of security in the form of a monkey patch for users who don't update `solidus_auth_devise`. For this reason, it has been marked as low impact on this end. ### Patches For extra security, update `solidus_core` to versions `3.1.3`, `3.0.3` or `2.11.12`. ### Workarounds Look at the workarounds described at [GHSA-xm34-v85h-9pg2](https://github.com/solidusio/solidus_auth_devise/security/advisories/GHSA-xm34-v85h-9pg2). ### References - [GHSA-xm34-v85h-9pg2](https://github.com/solidusio/solidus_auth_devise/security/advisories/GHSA-xm34-v85h-9pg2). ### For more information If you have any questions or comments about this advisory: * Open an issue in [solidus_auth_devise](https://github.com/solidusio/solidus_auth_devise/issues) or a discussion in [solidus](https://github.com/solidusio/solidus/discussions) * Email us at [[email protected]](mailto:[email protected]) * Contact the core team on [Slack](http://slack.solidus.io/)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | solidus_core (RubyGems) | before 2.11.12 | 2.11.12 | Patch available | GHSA-5629-8855-gf4g |
| — | solidus_core (RubyGems) | 3.0.0 to before 3.0.3 | 3.0.3 | Patch available | GHSA-5629-8855-gf4g |
| — | solidus_core (RubyGems) | 3.1.0 to before 3.1.3 | 3.1.3 | Patch available | GHSA-5629-8855-gf4g |
- solidus_core (RubyGems) Vendor— Affected before 2.11.12 Fixed in 2.11.12 Patch available GHSA-5629-8855-gf4g
- solidus_core (RubyGems) Vendor— Affected 3.0.0 to before 3.0.3 Fixed in 3.0.3 Patch available GHSA-5629-8855-gf4g
- solidus_core (RubyGems) Vendor— Affected 3.1.0 to before 3.1.3 Fixed in 3.1.3 Patch available GHSA-5629-8855-gf4g
Remediation
- Fix · GHSA-5629-8855-gf4g solidus_core (RubyGems) Fixed in 2.11.12 Advisory →
- Fix · GHSA-5629-8855-gf4g solidus_core (RubyGems) Fixed in 3.0.3 Advisory →
- Fix · GHSA-5629-8855-gf4g solidus_core (RubyGems) Fixed in 3.1.3 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-5629-8855-gf4g
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences