Apache Log4j Remote Code Execution
Key facts
- Attack vector
- —
- Privileges required
- —
- User interaction
- —
- Attack complexity
- —
- Impact type
- —
- Confidentiality · integrity · availability
- —
- Fix status
- Fixed
No CVSS vector from any source. Fix status from GitHub.
Summary
### Impact Opencast uses an Apache Log4j2 version which, combined with older JDK versions, can be used for remote code execution attacks which have been found to be actively exploited. Apache Log4j2 <=2.14.1 JNDI features is not sufficiently protected. An attacker who can control log messages or log message parameters can execute arbitrary code when message lookup substitution is enabled. ### Who is affected - Opencast before 9.10 or 10.6 are affected - Log4j version: all 2.x versions before 2.15.0 are affected ### Patches The issue has been fixed in Opencast 9.10 and 10.6. ### Workarounds The vulnerability can be mitigated by setting system property `log4j2.formatMsgNoLookups` to `true`. ### References - [Opencast pull request mitigating the vulnerability](https://github.com/opencast/opencast/pull/3253) - [CVE-2021-44228 Detail](https://nvd.nist.gov/vuln/detail/CVE-2021-44228) - [Analysis and Remediation Guidance to the Log4j Zero-Day RCE (CVE-2021-44228) Vulnerability](https://www.veracode.com/blog/security-news/urgent-analysis-and-remediation-guidance-log4j-zero-day-rce-cve-2021-44228) - [VE-2021-44228 – Log4j 2 Vulnerability Analysis](https://www.randori.com/blog/cve-2021-44228/) ### For more information If you have any questions or comments about this advisory: * Open an issue in [our issue tracker](https://github.com/opencast/opencast/issues) * Email us at [[email protected]](mailto:[email protected]) ### Note about dependencies This issue affects many Java applications. Please also verify these are not vulnerable.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | org.opencastproject:opencast-common (Maven) | before 9.10 | 9.10 | Patch available | GHSA-mf4f-j588-5xm8 |
| — | org.opencastproject:opencast-common (Maven) | 10.0 to before 10.6 | 10.6 | Patch available | GHSA-mf4f-j588-5xm8 |
- org.opencastproject:opencast-common (Maven) Vendor— Affected before 9.10 Fixed in 9.10 Patch available GHSA-mf4f-j588-5xm8
- org.opencastproject:opencast-common (Maven) Vendor— Affected 10.0 to before 10.6 Fixed in 10.6 Patch available GHSA-mf4f-j588-5xm8
Remediation
- Fix · GHSA-mf4f-j588-5xm8 org.opencastproject:opencast-common (Maven) Fixed in 9.10 Advisory →
- Fix · GHSA-mf4f-j588-5xm8 org.opencastproject:opencast-common (Maven) Fixed in 10.6 Advisory →
Timeline
- 2026-10-03 Threatist record created from GHSA-mf4f-j588-5xm8
References
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences