GlobalProtect App: Insufficiently Protected Credentials Vulnerability on Linux
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-522.
Summary
An insufficiently protected credentials vulnerability exists in the Palo Alto Networks GlobalProtect app on Linux that exposes the hashed credentials of GlobalProtect users that saved their password during previous GlobalProtect app sessions to other local users on the system. The exposed credentials enable a local attacker to authenticate to the GlobalProtect portal or gateway as the target user without knowing of the target user’s plaintext password. This issue impacts: GlobalProtect app 5.1 versions earlier than GlobalProtect app 5.1.10 on Linux. GlobalProtect app 5.2 versions earlier than and including GlobalProtect app 5.2.7 on Linux. GlobalProtect app 5.3 versions earlier than GlobalProtect app 5.3.2 on Linux. This issue does not affect the GlobalProtect app on other platforms.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Palo Alto Networks | GlobalProtect App | 5.3 to before 5.3.2; 5.2 – 5.2.7; 5.1 to before 5.1.10 | 5.3.2, 5.1.10 | Patch available | CNA |
- GlobalProtect App VendorPalo Alto Networks Affected 5.3 to before 5.3.2; 5.2 – 5.2.7; 5.1 to before 5.1.10 Fixed in 5.3.2, 5.1.10 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:paloaltonetworks:globalprotect:*:*:*:*:*:*:*:* | 5.1 to before 5.1.10; 5.2 – 5.2.7; 5.3 to before 5.3.2 | Vulnerable | CyberArk Software, a Palo Alto Networks Company |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Linux |
- cpe:2.3:a:paloaltonetworks:globalprotect:*:*:*:*:*:*:*:* Versions 5.1 to before 5.1.10; 5.2 – 5.2.7; 5.3 to before 5.3.2 Vulnerable ·CyberArk Software, a Palo Alto Networks Company
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Linux
Remediation
- Fix · CNA GlobalProtect App (Palo Alto Networks) Fixed in 5.3.2, 5.1.10
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0019
- 2026-10-03 Alias added: GHSA-w348-j94x-qjh2
References
More Palo Alto Networks vulnerabilities
- TI-2024-08782 Expedition: Unauthenticated OS Command Injection Vulnerability Leads to Firewall Credential Disclosure KEVCVSS 4.0CRITICAL 9.9
- TI-2024-03172 PAN-OS: Arbitrary File Creation Leads to OS Command Injection Vulnerability in GlobalProtect KEVCVSS 3.1CRITICAL 10.0
- TI-2020-01936 PAN-OS: Authentication Bypass in SAML Authentication KEVCVSS 3.1CRITICAL 10.0
- TI-2017-11675 Palo Alto Networks PAN-OS before 6.1.19, 7.0.x before 7.0.19, 7.1.x before 7.1.14, and… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-00239 PAN-OS: Unauthenticated user initiated Buffer Overflow Vulnerability in User-ID™ Authentication Portal KEVCVSS 4.0CRITICAL 9.3
- TI-2024-08784 Expedition: SQL Injection Leads to Firewall Admin Credential Disclosure KEVCVSS 4.0CRITICAL 9.2
Sources
- CVE-2022-0019 · CVE Program
- CVE-2022-0019 · NVD
- FIRST EPSS
- GHSA-w348-j94x-qjh2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences