Out-of-bounds Read in vim/vim
Priority LOW 38CWE-125Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
vim is vulnerable to Out-of-bounds Read
Why it matters now
EPSS 0.01861 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vim/vim (vim): 8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2 | 8.2 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2 Fixed in 8.2 Patch available CNA
CPE configurations NVD · 16
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 8.2.4009 | Vulnerable | vim |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* | 10.15.7 security_update_2020-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-001:*:*:*:*:*:* | 10.15.7 security_update_2021-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-002:*:*:*:*:*:* | 10.15.7 security_update_2021-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-003:*:*:*:*:*:* | 10.15.7 security_update_2021-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-004:*:*:*:*:*:* | 10.15.7 security_update_2021-004 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-005:*:*:*:*:*:* | 10.15.7 security_update_2021-005 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-006:*:*:*:*:*:* | 10.15.7 security_update_2021-006 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-007:*:*:*:*:*:* | 10.15.7 security_update_2021-007 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-008:*:*:*:*:*:* | 10.15.7 security_update_2021-008 | Vulnerable | Apple |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 8.2.4009 Vulnerable ·vim
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* Versions 10.15.7 security_update_2020-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-001:*:*:*:*:*:* Versions 10.15.7 security_update_2021-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-002:*:*:*:*:*:* Versions 10.15.7 security_update_2021-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-003:*:*:*:*:*:* Versions 10.15.7 security_update_2021-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-004:*:*:*:*:*:* Versions 10.15.7 security_update_2021-004 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-005:*:*:*:*:*:* Versions 10.15.7 security_update_2021-005 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-006:*:*:*:*:*:* Versions 10.15.7 security_update_2021-006 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-007:*:*:*:*:*:* Versions 10.15.7 security_update_2021-007 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-008:*:*:*:*:*:* Versions 10.15.7 security_update_2021-008 Vulnerable ·Apple
Show 6 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-001:*:*:*:*:*:* | 10.15.7 security_update_2022-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-002:*:*:*:*:*:* | 10.15.7 security_update_2022-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-003:*:*:*:*:*:* | 10.15.7 security_update_2022-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | before 10.15.7; 11.0 to before 11.6.6 | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:10.15.7:-:*:*:*:*:*:* | 10.15.7 | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:10.15.7:security_update_2022-004:*:*:*:*:*:* | 10.15.7 security_update_2022-004 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-001:*:*:*:*:*:* Versions 10.15.7 security_update_2022-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-002:*:*:*:*:*:* Versions 10.15.7 security_update_2022-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-003:*:*:*:*:*:* Versions 10.15.7 security_update_2022-003 Vulnerable ·Apple
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions before 10.15.7; 11.0 to before 11.6.6 Vulnerable ·Apple
- cpe:2.3:o:apple:macos:10.15.7:-:*:*:*:*:*:* Versions 10.15.7 Vulnerable ·Apple
- cpe:2.3:o:apple:macos:10.15.7:security_update_2022-004:*:*:*:*:*:* Versions 10.15.7 security_update_2022-004 Vulnerable ·Apple
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0128
- 2026-10-03 Alias added: GHSA-xvgc-v9fj-5m69
References
Advisory 8
- [oss-security] 20220114 Re: 3 new CVE's in vim
- https://support.apple.com/kb/HT213183
- 20220314 APPLE-SA-2022-03-14-4 macOS Monterey 12.3
- https://support.apple.com/kb/HT213256
- 20220516 APPLE-SA-2022-05-16-3 macOS Big Sur 11.6.6
- https://support.apple.com/kb/HT213343
- 20220721 APPLE-SA-2022-07-20-4 Security Update 2022-005 Catalina
- GLSA-202208-32
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2022-0128 · CVE Program
- CVE-2022-0128 · NVD
- FIRST EPSS
- GHSA-xvgc-v9fj-5m69 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0128 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences