Use After Free in vim/vim
Priority LOW 29CWE-416Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
vim is vulnerable to Use After Free
Why it matters now
EPSS 0.0184 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vim/vim (vim): 8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2 | 8.2 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2 Fixed in 8.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 8.2.4040 | Vulnerable | vim |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | before 12.3; 11.0 to before 11.6.8 | Vulnerable | Apple |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 8.2.4040 Vulnerable ·vim
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions before 12.3; 11.0 to before 11.6.8 Vulnerable ·Apple
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
vim/vim — FEDORA-2022-20e66c6698
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-00100 Heap-based Buffer Overflow in vim/vimPriority LOW 20
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0156
- 2026-10-03 Alias added: GHSA-3g57-r9p3-mh2v
References
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2022-0156 · CVE Program
- CVE-2022-0156 · NVD
- FIRST EPSS
- GHSA-3g57-r9p3-mh2v · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0156 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences