A flaw was found in the Linux kernel.
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.
Summary
A flaw was found in the Linux kernel. The existing KVM SEV API has a vulnerability that allows a non-root (host) user-level application to crash the host kernel by creating a confidential guest VM instance in AMD CPU that supports Secure Encrypted Virtualization (SEV).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | kernel | Fixed in kernel 5.18-rc4 | — | No fix listed | CNA |
- kernel Vendor— Affected Fixed in kernel 5.18-rc4 Fixed in — No fix listed CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 5.18 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:-:*:*:*:*:*:* | 5.18 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc1:*:*:*:*:*:* | 5.18 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc2:*:*:*:*:*:* | 5.18 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.18:rc3:*:*:*:*:*:* | 5.18 rc3 | Vulnerable | Linux |
| cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 5.18 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:-:*:*:*:*:*:* Versions 5.18 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc1:*:*:*:*:*:* Versions 5.18 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc2:*:*:*:*:*:* Versions 5.18 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.18:rc3:*:*:*:*:*:* Versions 5.18 rc3 Vulnerable ·Linux
- cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix yet |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0171
- 2026-10-03 Alias added: GHSA-963w-7frp-mf37
- 2026-11-02 CISA SSVC decision points changed
References
Patch 2
Sources
- CVE-2022-0171 · CVE Program
- CVE-2022-0171 · NVD
- FIRST EPSS
- GHSA-963w-7frp-mf37 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0171 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences