Cross-site Scripting (XSS) - Stored in pimcore/pimcore
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
pimcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Why it matters now
EPSS 0.00642 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pimcore/pimcore (Packagist): 10.2.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pimcore | pimcore/pimcore | up to 10.2.8 | — | No fix listed | CNA |
| — | pimcore/pimcore (Packagist) | before 10.2.9 | 10.2.9 | Patch available | GHSA-57hg-26h7-9qgv |
- pimcore/pimcore Vendorpimcore Affected up to 10.2.8 Fixed in — No fix listed CNA
- pimcore/pimcore (Packagist) Vendor— Affected before 10.2.9 Fixed in 10.2.9 Patch available GHSA-57hg-26h7-9qgv
Remediation
- Fix · GHSA-57hg-26h7-9qgv pimcore/pimcore (Packagist) Fixed in 10.2.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0256
- 2026-10-03 Alias added: GHSA-57hg-26h7-9qgv
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
More Pimcore vulnerabilities
- TI-2026-18925 Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 CVSS 3.1HIGH 8.8
- TI-2026-18926 Pimcore ENV Variables and Cookie Informations are exposed in http_error_log CVSS 3.1HIGH 8.6
- TI-2023-01489 SQL Injection in pimcore/pimcore CVSS 3.1HIGH 8.8
- TI-2019-08091 An issue was discovered in Pimcore before 5.7.1. CVSS 3.0HIGH 8.8
- TI-2023-25778 SQL Injection in Admin Grid Filter API in Pimcore CVSS 3.1HIGH 8.8
- TI-2023-10682 An improper SameSite Attribute vulnerability in pimCore v10.5.15 allows attackers to execute arbitrary code. CVSS 3.1HIGH 8.8
Sources
- CVE-2022-0256 · CVE Program
- CVE-2022-0256 · NVD
- FIRST EPSS
- GHSA-57hg-26h7-9qgv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences