Improper Neutralization of Special Elements Used in a Template Engine in bobthecow/mustache.php
Priority LOW 39CWE-1336Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1336.
Summary
Improper Neutralization of Special Elements Used in a Template Engine in Packagist mustache/mustache prior to 2.14.1.
Why it matters now
EPSS 0.00672 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed bobthecow/mustache.php (bobthecow): 2.14.1mustache/mustache (Packagist): 2.14.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| bobthecow | bobthecow/mustache.php | before 2.14.1 | 2.14.1 | Patch available | CNA |
| — | mustache/mustache (Packagist) | 2.0.0 to before 2.14.1 | 2.14.1 | Patch available | GHSA-4rmr-c2jx-vx27 |
- bobthecow/mustache.php Vendorbobthecow Affected before 2.14.1 Fixed in 2.14.1 Patch available CNA
- mustache/mustache (Packagist) Vendor— Affected 2.0.0 to before 2.14.1 Fixed in 2.14.1 Patch available GHSA-4rmr-c2jx-vx27
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mustache_project:mustache:*:*:*:*:*:php:*:* | 2.0.0 to before 2.14.1 | Vulnerable | Mustache Project |
- cpe:2.3:a:mustache_project:mustache:*:*:*:*:*:php:*:* Versions 2.0.0 to before 2.14.1 Vulnerable ·Mustache Project
Remediation
- Fix · CNA bobthecow/mustache.php (bobthecow) Fixed in 2.14.1
- Fix · GHSA-4rmr-c2jx-vx27 mustache/mustache (Packagist) Fixed in 2.14.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0323
- 2026-10-03 Alias added: GHSA-4rmr-c2jx-vx27
References
Sources
- CVE-2022-0323 · CVE Program
- CVE-2022-0323 · NVD
- FIRST EPSS
- GHSA-4rmr-c2jx-vx27 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences