Improper Removal of Sensitive Information Before Storage or Transfer in feross/simple-get
Priority MEDIUM 42CWE-212Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
Improper Removal of Sensitive Information Before Storage or Transfer in NPM simple-get prior to 4.0.1.
Why it matters now
EPSS 0.02024 81st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial feross/simple-get (feross): 4.0.1simple-get (npm): 4.0.1, 3.1.1, 2.8.2Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| feross | feross/simple-get | before 4.0.1 | 4.0.1 | Patch available | CNA |
| — | simple-get (npm) | 4.0.0 to before 4.0.1 | 4.0.1 | Patch available | GHSA-wpg7-2c88-r8xv |
| — | simple-get (npm) | 3.0.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-wpg7-2c88-r8xv |
| — | simple-get (npm) | before 2.8.2 | 2.8.2 | Patch available | GHSA-wpg7-2c88-r8xv |
- feross/simple-get Vendorfeross Affected before 4.0.1 Fixed in 4.0.1 Patch available CNA
- simple-get (npm) Vendor— Affected 4.0.0 to before 4.0.1 Fixed in 4.0.1 Patch available GHSA-wpg7-2c88-r8xv
- simple-get (npm) Vendor— Affected 3.0.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-wpg7-2c88-r8xv
- simple-get (npm) Vendor— Affected before 2.8.2 Fixed in 2.8.2 Patch available GHSA-wpg7-2c88-r8xv
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simple-get_project:simple-get:*:*:*:*:*:node.js:*:* | before 2.8.2; 3.0.0 to before 3.1.1 | Vulnerable | Simple-get Project |
| cpe:2.3:a:simple-get_project:simple-get:4.0.0:*:*:*:*:node.js:*:* | 4.0.0 | Vulnerable | Simple-get Project |
- cpe:2.3:a:simple-get_project:simple-get:*:*:*:*:*:node.js:*:* Versions before 2.8.2; 3.0.0 to before 3.1.1 Vulnerable ·Simple-get Project
- cpe:2.3:a:simple-get_project:simple-get:4.0.0:*:*:*:*:node.js:*:* Versions 4.0.0 Vulnerable ·Simple-get Project
Remediation
- Fix · CNA feross/simple-get (feross) Fixed in 4.0.1
- Fix · GHSA-wpg7-2c88-r8xv simple-get (npm) Fixed in 4.0.1 Advisory →
- Fix · GHSA-wpg7-2c88-r8xv simple-get (npm) Fixed in 3.1.1 Advisory →
- Fix · GHSA-wpg7-2c88-r8xv simple-get (npm) Fixed in 2.8.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Advanced Cluster Management for Kubernetes 2 | Affected | No fix planned: Will not fix |
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0355
- 2026-10-03 Alias added: GHSA-wpg7-2c88-r8xv
References
Advisory 2
Sources
- CVE-2022-0355 · CVE Program
- CVE-2022-0355 · NVD
- FIRST EPSS
- GHSA-wpg7-2c88-r8xv · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0355 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences