Out-of-bounds Read in vim/vim
Priority LOW 37CWE-125Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Out-of-bounds Read in GitHub repository vim/vim prior to 8.2.
Why it matters now
EPSS 0.01521 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vim/vim (vim): 8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2 | 8.2 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2 Fixed in 8.2 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 8.2.4217 | Vulnerable | vim |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | 12.0 to before 12.6 | Vulnerable | Apple |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 8.2.4217 Vulnerable ·vim
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions 12.0 to before 12.6 Vulnerable ·Apple
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
vim/vim 8.2
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-00286 Heap-based Buffer Overflow in vim/vimPriority LOW 37
- TI-2022-00284 Heap-based Buffer Overflow in vim/vimPriority LOW 37
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 8 products
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat OpenShift Virtualization 2
- Red Hat OpenShift Virtualization 4
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0368
- 2026-10-03 Alias added: GHSA-h4rr-269p-4557
References
Advisory 8
- [debian-lts-announce] 20220311 [SECURITY] [DLA 2947-1] vim security update
- GLSA-202208-32
- https://support.apple.com/kb/HT213444
- https://support.apple.com/kb/HT213488
- 20221030 APPLE-SA-2022-10-27-5 Additional information for APPLE-SA-2022-10-24-2 macOS Ventura 13
- 20221030 APPLE-SA-2022-10-24-2 macOS Ventura 13
- 20221030 APPLE-SA-2022-10-27-7 Additional information for APPLE-SA-2022-09-12-4 macOS Monterey 12.6
- [debian-lts-announce] 20221108 [SECURITY] [DLA 3182-1] vim security update
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2022-0368 · CVE Program
- CVE-2022-0368 · NVD
- FIRST EPSS
- GHSA-h4rr-269p-4557 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0368 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences