Read the docs
TI-2022-00365 Aliases CVE-2022-0442GHSA-37f6-m354-672c

UsersWP < 1.2.3.1 - Subscriber+ User Avatar Override

Priority LOW 21CWE-639Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-639.

Summary

The UsersWP WordPress plugin before 1.2.3.1 is missing access controls when updating a user avatar, and does not make sure file names for user avatars are unique, allowing a logged in user to overwrite another users avatar.

Why it matters now

EPSS 0.00654 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed UsersWP – User Registration & User Profile (Unknown): 1.2.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownUsersWP – User Registration & User Profile1.2.3.1 to before 1.2.3.11.2.3.1Patch availableCNA
  • UsersWP – User Registration & User Profile VendorUnknown Affected 1.2.3.1 to before 1.2.3.1 Fixed in 1.2.3.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ayecode:userswp:*:*:*:*:*:wordpress:*:*before 1.2.3.1VulnerableAyeCode Ltd
  • cpe:2.3:a:ayecode:userswp:*:*:*:*:*:wordpress:*:* Versions before 1.2.3.1 Vulnerable ·AyeCode Ltd

Remediation

  • Fix · CNA UsersWP – User Registration & User Profile (Unknown) Fixed in 1.2.3.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0442
  2. 2026-10-03 Alias added: GHSA-37f6-m354-672c
  3. 2026-10-14 EPSS moved to the 50th–90th percentile

References

  • TI-2024-06008 UsersWP < 1.2.12 - Users Information Disclosure CVSS 3.1HIGH 7.5
  • TI-2024-05812 SQL injection in stiofansisland UsersWP – Front-end login form, User Registration, User… CVSS 3.1CRITICAL 9.8
  • TI-2022-23519 WordPress UsersWP Plugin <= 1.2.3.9 is vulnerable to CSV Injection CVSS 3.1HIGH 8.8
  • TI-2024-02251 UsersWP <= 1.2.6 - Authenticated(Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4

Sources