Menu Image, Icons made easy < 3.0.8 - Subscriber+ Stored Cross-Site Scripting
Priority LOW 25CWE-116Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Menu Image, Icons made easy WordPress plugin before 3.0.6 does not have authorisation and CSRF checks when saving menu settings, and does not validate, sanitise and escape them. As a result, any authenticate users, such as subscriber can update the settings or arbitrary menu and put Cross-Site Scripting payloads in them which will be triggered in the related menu in the frontend
Why it matters now
EPSS 0.00604 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Menu Image, Icons made easy (Unknown): 3.0.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Menu Image, Icons made easy | before 3.0.6 | 3.0.6 | Patch available | CNA |
- Menu Image, Icons made easy VendorUnknown Affected before 3.0.6 Fixed in 3.0.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:freshlightlab:menu_image\,_icons_made_easy:*:*:*:*:*:wordpress:*:* | before 3.0.8 | Vulnerable | Freshlight Lab |
- cpe:2.3:a:freshlightlab:menu_image\,_icons_made_easy:*:*:*:*:*:wordpress:*:* Versions before 3.0.8 Vulnerable ·Freshlight Lab
Remediation
- Fix · CNA Menu Image, Icons made easy (Unknown) Fixed in 3.0.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0450
- 2026-10-03 Alias added: GHSA-rwc4-w23c-gc77
References
More Freshlight Lab Menu Image, Icons Made Easy vulnerabilities
- TI-2023-27731 WordPress Menu Image, Icons made easy Plugin <= 3.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-0450 · CVE Program
- CVE-2022-0450 · NVD
- FIRST EPSS
- GHSA-rwc4-w23c-gc77 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences