BulletProof Security < 5.8 - Admin+ Stored Cross-Site Scripting (XSS)
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The BulletProof Security WordPress plugin before 5.8 does not sanitise and escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed BulletProof Security (Unknown): 5.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | BulletProof Security | 5.8 to before 5.8 | 5.8 | Patch available | CNA |
- BulletProof Security VendorUnknown Affected 5.8 to before 5.8 Fixed in 5.8 Patch available CNA
Remediation
- Fix · CNA BulletProof Security (Unknown) Fixed in 5.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0590
- 2026-10-03 Alias added: GHSA-92j5-277h-r47f
References
More AITpro Bulletproof Security vulnerabilities
- TI-2021-16696 BulletProof Security <= 5.1 Sensitive Information Disclosure CVSS 3.1MEDIUM 5.3
- TI-2014-06621 SQL injection vulnerability in admin/htaccess/bpsunlock.php in the BulletProof Security… CVSS 2.0MEDIUM 6.5
- TI-2014-07178 Server-side request forgery (SSRF) vulnerability in admin/htaccess/bpsunlock.php in the… CVSS 2.0MEDIUM 5.0
- TI-2015-07610 In the admin/db-backup-security/db-backup-security.php page in the BulletProof Security… CVSS 3.1MEDIUM 4.8
- TI-2014-06620 Cross-site scripting (XSS) vulnerability in admin/htaccess/bpsunlock.php in the… CVSS 2.0MEDIUM 4.3
- TI-2022-01150 BulletProof Security < 6.1 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-0590 · CVE Program
- CVE-2022-0590 · NVD
- FIRST EPSS
- GHSA-92j5-277h-r47f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences