Generation of Error Message Containing Sensitive Information in snipe/snipe-it
Priority LOW 26CWE-209Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-209.
Summary
Generation of Error Message Containing Sensitive Information in Packagist snipe/snipe-it prior to 5.3.11.
Why it matters now
EPSS 0.00988 62nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed snipe/snipe-it (snipe): 5.3.11snipe/snipe-it (Packagist): 5.3.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| grokability | snipe/snipe-it | before 5.3.11 | 5.3.11 | Patch available | CNA |
| — | snipe/snipe-it (Packagist) | before 5.3.11 | 5.3.11 | Patch available | GHSA-pwwm-pwx2-2hw7 |
- snipe/snipe-it Vendorgrokability Affected before 5.3.11 Fixed in 5.3.11 Patch available CNA
- snipe/snipe-it (Packagist) Vendor— Affected before 5.3.11 Fixed in 5.3.11 Patch available GHSA-pwwm-pwx2-2hw7
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:snipeitapp:snipe-it:*:*:*:*:*:*:*:* | up to 5.3.10 | Vulnerable | grokability |
| cpe:2.3:a:snipeitapp:snipe-it:6.0.0:rc1:*:*:*:*:*:* | 6.0.0 rc1 | Vulnerable | grokability |
| cpe:2.3:a:snipeitapp:snipe-it:6.0.0:rc2:*:*:*:*:*:* | 6.0.0 rc2 | Vulnerable | grokability |
- cpe:2.3:a:snipeitapp:snipe-it:*:*:*:*:*:*:*:* Versions up to 5.3.10 Vulnerable ·grokability
- cpe:2.3:a:snipeitapp:snipe-it:6.0.0:rc1:*:*:*:*:*:* Versions 6.0.0 rc1 Vulnerable ·grokability
- cpe:2.3:a:snipeitapp:snipe-it:6.0.0:rc2:*:*:*:*:*:* Versions 6.0.0 rc2 Vulnerable ·grokability
Remediation
- Fix · CNA snipe/snipe-it (snipe) Fixed in 5.3.11
- Fix · GHSA-pwwm-pwx2-2hw7 snipe/snipe-it (Packagist) Fixed in 5.3.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0622
- 2026-10-03 Alias added: GHSA-pwwm-pwx2-2hw7
References
More grokability Snipe-it vulnerabilities
- TI-2026-45238 Snipe-IT: Stored XSS via Inline XML Rendering in the Uploaded Files API CVSS 3.1HIGH 8.7
- TI-2026-59327 Snipe-IT before 8.7.0 Authentication Bypass via SAML Username Collation CVSS 4.0HIGH 8.6
- TI-2026-44513 Snipe-IT: Stored XSS via Custom Field name in asset-list column headers CVSS 3.1HIGH 8.4
- TI-2023-05072 Cross-Site Request Forgery (CSRF) in snipe/snipe-it CVSS 3.1HIGH 8.8
- TI-2026-59308 Snipe-IT before 8.7.0 Arbitrary File Read and SSRF via Markdown CVSS 4.0HIGH 8.4
- TI-2026-59298 Snipe-IT before 8.7.0 Arbitrary File Read and SSRF via Category EULA CVSS 4.0HIGH 8.4
Sources
- CVE-2022-0622 · CVE Program
- CVE-2022-0622 · NVD
- FIRST EPSS
- GHSA-pwwm-pwx2-2hw7 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0622 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences