Exposure of Sensitive Information to an Unauthorized Actor in fgribreau/node-request-retry
Priority LOW 36CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository fgribreau/node-request-retry prior to 7.0.0.
Why it matters now
EPSS 0.01423 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed fgribreau/node-request-retry (fgribreau): 7.0.0requestretry (npm): 7.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fgribreau | fgribreau/node-request-retry | before 7.0.0 | 7.0.0 | Patch available | CNA |
| — | requestretry (npm) | before 7.0.0 | 7.0.0 | Patch available | GHSA-hjp8-2cm3-cc45 |
- fgribreau/node-request-retry Vendorfgribreau Affected before 7.0.0 Fixed in 7.0.0 Patch available CNA
- requestretry (npm) Vendor— Affected before 7.0.0 Fixed in 7.0.0 Patch available GHSA-hjp8-2cm3-cc45
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:node-request-retry_project:node-request-retry:*:*:*:*:*:node.js:*:* | before 7.0.0 | Vulnerable | Node-request-retry Project |
- cpe:2.3:a:node-request-retry_project:node-request-retry:*:*:*:*:*:node.js:*:* Versions before 7.0.0 Vulnerable ·Node-request-retry Project
Remediation
- Fix · CNA fgribreau/node-request-retry (fgribreau) Fixed in 7.0.0
- Fix · GHSA-hjp8-2cm3-cc45 requestretry (npm) Fixed in 7.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0654
- 2026-10-03 Alias added: GHSA-hjp8-2cm3-cc45
References
Sources
- CVE-2022-0654 · CVE Program
- CVE-2022-0654 · NVD
- FIRST EPSS
- GHSA-hjp8-2cm3-cc45 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences