Insufficiently protected credentials in openstack/python-oslo.utils
Priority LOW 26CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 2 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-522.
Summary
A flaw was found in python-oslo-utils. Due to improper parsing, passwords with a double quote ( " ) in them cause incorrect masking in debug logs, causing any part of the password after the double quote to be plaintext.
Why it matters now
EPSS 0.01859 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial oslo-utils (PyPI): 4.10.1Red Hat: 2 advisoriesRed Hat: 2 fixed, 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | openstack/python-oslo.utils | Affects all versions, Fixed in 4.10.1, 4.12.1. | — | No fix listed | CNA |
| — | oslo-utils (PyPI) | before 4.10.1 | 4.10.1 | Patch available | GHSA-wmqq-r32m-87c5 |
- openstack/python-oslo.utils Vendor— Affected Affects all versions, Fixed in 4.10.1, 4.12.1. Fixed in — No fix listed CNA
- oslo-utils (PyPI) Vendor— Affected before 4.10.1 Fixed in 4.10.1 Patch available GHSA-wmqq-r32m-87c5
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openstack:oslo.utils:*:*:*:*:*:*:*:* | before 4.10.1 | Vulnerable | OpenStack |
| cpe:2.3:a:openstack:oslo.utils:4.12.0:*:*:*:*:*:*:* | 4.12.0 | Vulnerable | OpenStack |
| cpe:2.3:a:redhat:openshift_container_platform:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Red Hat |
| cpe:2.3:a:redhat:openstack_platform:16.1:*:*:*:*:*:*:* | 16.1 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:openstack:oslo.utils:*:*:*:*:*:*:*:* Versions before 4.10.1 Vulnerable ·OpenStack
- cpe:2.3:a:openstack:oslo.utils:4.12.0:*:*:*:*:*:*:* Versions 4.12.0 Vulnerable ·OpenStack
- cpe:2.3:a:redhat:openshift_container_platform:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Red Hat
- cpe:2.3:a:redhat:openstack_platform:16.1:*:*:*:*:*:*:* Versions 16.1 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-wmqq-r32m-87c5 oslo-utils (PyPI) Fixed in 4.10.1 Advisory →
Red Hat 2 advisories
- RHSA-2022:8873 Released 2022-12-07 · Red Hat rating ModerateRed Hat OpenStack Platform 16.1.9 (python-oslo-utils) security update
- Red Hat OpenStack Platform 16.1 python-oslo-utils-3.41.6-1.20220426095230.f4deaad.el8ost, python-oslo-utils-lang-3.41.6-1.20220426095230.f4deaad.el8ost, python3-oslo-utils-3.41.6-1.20220426095230.f4deaad.el8ost
- RHSA-2022:0993 Released 2022-03-23 · Red Hat rating ModerateRed Hat OpenStack Platform 16.2 (python-oslo-utils) security update
- Red Hat OpenStack Platform 16.2 python-oslo-utils-3.41.6-2.20220111011750.el8ost, python-oslo-utils-lang-3.41.6-2.20220111011750.el8ost, python3-oslo-utils-3.41.6-2.20220111011750.el8ost
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
| Red Hat OpenStack Platform 13 (Queens) | Affected | No fix planned: Out of support scope |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 16.1 | Fixed | RHSA-2022:8873 |
| Red Hat OpenStack Platform 16.2 | Fixed | RHSA-2022:0993 |
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0718
- 2026-10-03 Alias added: GHSA-wmqq-r32m-87c5
References
Patch 3
Advisory 4
Sources
- CVE-2022-0718 · CVE Program
- CVE-2022-0718 · NVD
- FIRST EPSS
- GHSA-wmqq-r32m-87c5 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-0718 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences