Text Hover < 4.2 - Admin+ Stored Cross-Site Scripting
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Text Hover WordPress plugin before 4.2 does not sanitize and escape the text to hover, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00812 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Text Hover (Unknown): 4.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Text Hover | 4.2 to before 4.2 | 4.2 | Patch available | CNA |
- Text Hover VendorUnknown Affected 4.2 to before 4.2 Fixed in 4.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:text_hover_project:text_hover:*:*:*:*:*:wordpress:*:* | before 4.2 | Vulnerable | Text Hover Project |
- cpe:2.3:a:text_hover_project:text_hover:*:*:*:*:*:wordpress:*:* Versions before 4.2 Vulnerable ·Text Hover Project
Remediation
- Fix · CNA Text Hover (Unknown) Fixed in 4.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0737
- 2026-10-03 Alias added: GHSA-xg54-3m24-j48q
References
Sources
- CVE-2022-0737 · CVE Program
- CVE-2022-0737 · NVD
- FIRST EPSS
- GHSA-xg54-3m24-j48q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences