Read the docs
TI-2022-00652 Aliases CVE-2022-0740GHSA-rq9r-r987-7r36

Incorrect authorization in GitLab

Priority LOW 22CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.

Summary

Incorrect authorization in the Asana integration's branch restriction feature in all versions of GitLab CE/EE starting from version 7.8.0 before 14.7.7, all versions starting from 14.8 before 14.8.5, all versions starting from 14.9 before 14.9.2 makes it possible to close Asana tasks from unrestricted branches.

Why it matters now

EPSS 0.00984 62nd percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.7.7, 14.8.5, 14.9.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitLabGitLab7.8 to before 14.7.7; 14.8 to before 14.8.5; 14.9 to before 14.9.214.7.7, 14.8.5, 14.9.2Patch availableCNA
  • GitLab VendorGitLab Affected 7.8 to before 14.7.7; 14.8 to before 14.8.5; 14.9 to before 14.9.2 Fixed in 14.7.7, 14.8.5, 14.9.2 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*7.8.0 to before 14.7.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*7.8.0 to before 14.7.7VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*14.8.0 to before 14.8.5VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*14.8.0 to before 14.8.5VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*14.9.0 to before 14.9.2VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*14.9.0 to before 14.9.2VulnerableGitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 7.8.0 to before 14.7.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 7.8.0 to before 14.7.7 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.8.0 to before 14.8.5 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.8.0 to before 14.8.5 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.9.0 to before 14.9.2 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.9.0 to before 14.9.2 Vulnerable ·GitLab

Remediation

  • Fix · CNA GitLab (GitLab) Fixed in 14.7.7, 14.8.5, 14.9.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0740
  2. 2026-10-03 Alias added: GHSA-rq9r-r987-7r36

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
See all 1506 →

Sources