SearchIQ < 3.9 - Unauthenticated Stored XSS
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The SearchIQ WordPress plugin before 3.9 contains a flag to disable the verification of CSRF nonces, granting unauthenticated attackers access to the siq_ajax AJAX action and allowing them to perform Cross-Site Scripting attacks due to the lack of sanitisation and escaping in the customCss parameter
Why it matters now
EPSS 0.00866 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed SearchIQ – The Search Solution (Unknown): 3.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | SearchIQ – The Search Solution | 3.9 to before 3.9 | 3.9 | Patch available | CNA |
- SearchIQ – The Search Solution VendorUnknown Affected 3.9 to before 3.9 Fixed in 3.9 Patch available CNA
Remediation
- Fix · CNA SearchIQ – The Search Solution (Unknown) Fixed in 3.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0780
- 2026-10-03 Alias added: GHSA-xpxf-4p9g-j69p
References
More Searchiq vulnerabilities
- TI-2024-20635 WordPress SearchIQ plugin <= 4.5 - Sensitive Data Exposure via Log File vulnerability CVSS 3.1HIGH 7.5
- TI-2023-25940 WordPress SearchIQ plugin <= 4.4 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2025-22137 WordPress SearchIQ plugin <= 4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-12392 SearchIQ – The Search Solution <= 4.7 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-10091 SearchIQ – The Search Solution <= 4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2024-37199 WordPress SearchIQ plugin <= 4.6 - Cross-Site Requst Forgery (CSRF) vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-0780 · CVE Program
- CVE-2022-0780 · NVD
- FIRST EPSS
- GHSA-xpxf-4p9g-j69p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences