Read the docs
TI-2022-00747 Aliases CVE-2022-0840GHSA-qp34-j2qv-6pv6

Easy Social Icons < 3.2.1 - Admin+ Stored Cross-Site Scripting in add icon

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Easy Social Icons WordPress plugin before 3.2.1 does not properly escape the image_file field when adding a new social icon, allowing high privileged users to inject arbitrary javascript even when the unfiltered_html capability is disallowed.

Why it matters now

EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Easy Social Icons (Unknown): 3.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownEasy Social Icons3.2.1 to before 3.2.13.2.1Patch availableCNA
  • Easy Social Icons VendorUnknown Affected 3.2.1 to before 3.2.1 Fixed in 3.2.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cybernetikz:easy_social_icons:*:*:*:*:*:wordpress:*:*before 3.2.1Vulnerablecybernetikz
  • cpe:2.3:a:cybernetikz:easy_social_icons:*:*:*:*:*:wordpress:*:* Versions before 3.2.1 Vulnerable ·cybernetikz

Remediation

  • Fix · CNA Easy Social Icons (Unknown) Fixed in 3.2.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-0840
  2. 2026-10-03 Alias added: GHSA-qp34-j2qv-6pv6

References

  • TI-2015-01871 Cross-site request forgery (CSRF) vulnerability in the Easy Social Icons plugin before… CVSS 2.0MEDIUM 6.8
  • TI-2022-00791 Easy Social Icons < 3.1.4 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
  • TI-2021-16694 Easy Social Icons <= 3.0.8 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2023-26199 WordPress Easy Social Icons Plugin <= 3.2.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources