UpdraftPlus < 1.22.9 - Reflected Cross-Site Scripting
Priority LOW 37CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The UpdraftPlus WordPress Backup Plugin WordPress plugin before 1.22.9 does not sanitise and escape the updraft_interval parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting (XSS) vulnerability.
Why it matters now
EPSS 0.07415 94th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed UpdraftPlus WordPress Backup Plugin (Unknown): 1.22.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | UpdraftPlus WordPress Backup Plugin | 1.22.9 to before 1.22.9 | 1.22.9 | Patch available | CNA |
- UpdraftPlus WordPress Backup Plugin VendorUnknown Affected 1.22.9 to before 1.22.9 Fixed in 1.22.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:updraftplus:updraftplus:*:*:*:*:*:wordpress:*:* | before 1.22.9 | Vulnerable | UpdraftPlus |
- cpe:2.3:a:updraftplus:updraftplus:*:*:*:*:*:wordpress:*:* Versions before 1.22.9 Vulnerable ·UpdraftPlus
Remediation
- Fix · CNA UpdraftPlus WordPress Backup Plugin (Unknown) Fixed in 1.22.9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0864
- 2026-10-03 Alias added: GHSA-2pp2-5h73-4wxg
References
More Updraftplus vulnerabilities
- TI-2021-07300 UpdraftPlus < 1.16.66 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2017-12417 The UpdraftPlus plugin through 1.13.12 for WordPress allows remote PHP code execution… CVSS 3.0HIGH 8.1
- TI-2017-12416 The UpdraftPlus plugin through 1.13.12 for WordPress has SSRF in the updraft_ajax_handler… CVSS 3.0HIGH 8.1
- TI-2022-00550 UpdraftPlus Free < 1.22.3 & Premium < 2.22.3 - Subscriber+ Backup Download CVSS 3.1MEDIUM 6.5
- TI-2023-16148 WordPress UpdraftPlus Plugin <= 1.23.3 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 7.1
- TI-2021-07367 UpdraftPlus < 1.16.69 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-0864 · CVE Program
- CVE-2022-0864 · NVD
- FIRST EPSS
- GHSA-2pp2-5h73-4wxg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences