Mark Posts < 2.0.1 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Mark Posts WordPress plugin before 2.0.1 does not escape new markers, allowing high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00654 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Mark Posts (Unknown): 2.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Mark Posts | 2.0.1 to before 2.0.1 | 2.0.1 | Patch available | CNA |
- Mark Posts VendorUnknown Affected 2.0.1 to before 2.0.1 Fixed in 2.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mark_posts_project:mark_posts:*:*:*:*:*:wordpress:*:* | before 2.0.1 | Vulnerable | Mark Posts Project |
- cpe:2.3:a:mark_posts_project:mark_posts:*:*:*:*:*:wordpress:*:* Versions before 2.0.1 Vulnerable ·Mark Posts Project
Remediation
- Fix · CNA Mark Posts (Unknown) Fixed in 2.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0958
- 2026-10-03 Alias added: GHSA-5x9g-xc83-f9vr
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2022-0958 · CVE Program
- CVE-2022-0958 · NVD
- FIRST EPSS
- GHSA-5x9g-xc83-f9vr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences