Read the docs
TI-2022-00924 Aliases CVE-2022-1027GHSA-7fmh-wc5m-w4rx

Page Restriction WordPress < 1.2.7 - Admin+ Stored Cross-Site Scripting

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Page Restriction WordPress (WP) WordPress plugin before 1.2.7 allows bad actors with administrator privileges to the settings page to inject Javascript code to its settings leading to stored Cross-Site Scripting that will only affect administrator users.

Why it matters now

EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Page Restriction WordPress (WP) – Protect WP Pages/Post (Unknown): 1.2.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPage Restriction WordPress (WP) – Protect WP Pages/Post1.2.7 to before 1.2.71.2.7Patch availableCNA
  • Page Restriction WordPress (WP) – Protect WP Pages/Post VendorUnknown Affected 1.2.7 to before 1.2.7 Fixed in 1.2.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:minioragne:page_restriction:*:*:*:*:*:wordpress:*:*before 1.2.7VulnerableMinioragne
  • cpe:2.3:a:minioragne:page_restriction:*:*:*:*:*:wordpress:*:* Versions before 1.2.7 Vulnerable ·Minioragne

Remediation

  • Fix · CNA Page Restriction WordPress (WP) – Protect WP Pages/Post (Unknown) Fixed in 1.2.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1027
  2. 2026-10-03 Alias added: GHSA-7fmh-wc5m-w4rx

References

Sources