LayerSlider < 7.1.2 - Admin+ Stored Cross-Site Scripting
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The LayerSlider WordPress plugin before 7.1.2 does not sanitise and escape Project's slug before outputting it back in various place, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Why it matters now
EPSS 0.0309 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed LayerSlider (Unknown): 7.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LayerSlider | 7.1.2 to before 7.1.2 | 7.1.2 | Patch available | CNA |
- LayerSlider VendorUnknown Affected 7.1.2 to before 7.1.2 Fixed in 7.1.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kreaturamedia:layerslider:*:*:*:*:*:wordpress:*:* | before 7.1.2 | Vulnerable | LayerSlider |
- cpe:2.3:a:kreaturamedia:layerslider:*:*:*:*:*:wordpress:*:* Versions before 7.1.2 Vulnerable ·LayerSlider
Remediation
- Fix · CNA LayerSlider (Unknown) Fixed in 7.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1153
- 2026-10-03 Alias added: GHSA-fq4m-w42p-h4c2
References
More Layerslider vulnerabilities
- TI-2024-02687 SQL injection in LayerSlider CVSS 3.1CRITICAL 9.8
- TI-2023-25895 WordPress LayerSlider Plugin <= 7.7.9 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-25896 WordPress LayerSlider Plugin <= 7.7.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-1153 · CVE Program
- CVE-2022-1153 · NVD
- FIRST EPSS
- GHSA-fq4m-w42p-h4c2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences