Use after free in utf_ptr2char in vim/vim
Priority LOW 37CWE-416Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 fixed, 3 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-416 and the CVSS impact.
Summary
Use after free in utf_ptr2char in GitHub repository vim/vim prior to 8.2.4646.
Why it matters now
EPSS 0.01462 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial vim/vim (vim): 8.2.4646Red Hat: 2 advisoriesRed Hat: 4 fixed, 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2.4646 | 8.2.4646 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2.4646 Fixed in 8.2.4646 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 8.2.4646 | Vulnerable | vim |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:oracle:communications_cloud_native_core_network_exposure_function:22.1.1:*:*:*:*:*:*:* | 22.1.1 | Vulnerable | Oracle |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 8.2.4646 Vulnerable ·vim
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:oracle:communications_cloud_native_core_network_exposure_function:22.1.1:*:*:*:*:*:*:* Versions 22.1.1 Vulnerable ·Oracle
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2.4646
Red Hat 2 advisories
- RHSA-2022:5242 Released 2022-07-01 · Red Hat rating Moderatevim security update
- Red Hat Enterprise Linux AppStream (v. 9) vim-X11-2:8.2.2637-16.el9_0.2, vim-common-2:8.2.2637-16.el9_0.2, vim-enhanced-2:8.2.2637-16.el9_0.2
- Red Hat Enterprise Linux BaseOS (v. 9) vim-2:8.2.2637-16.el9_0.2, vim-filesystem-2:8.2.2637-16.el9_0.2, vim-minimal-2:8.2.2637-16.el9_0.2
- RHSA-2022:1552 Released 2022-04-26 · Red Hat rating Moderatevim security update
- Red Hat Enterprise Linux AppStream (v. 8) vim-X11-2:8.0.1763-16.el8_5.13, vim-common-2:8.0.1763-16.el8_5.13, vim-enhanced-2:8.0.1763-16.el8_5.13 +1
- Red Hat Enterprise Linux BaseOS (v. 8) vim-2:8.0.1763-16.el8_5.13, vim-minimal-2:8.0.1763-16.el8_5.13
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
vim/vim — FEDORA-2022-d776fcfe60
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-01049 heap buffer overflow in get_one_sourceline in vim/vimPriority LOW 37
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Virtualization 4 | Affected | No fix yet |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2022:1552 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:5242 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2022:1552 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2022:5242 |
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1154
- 2026-10-03 Alias added: GHSA-wm74-7g5x-vq4x
References
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2022-1154 · CVE Program
- CVE-2022-1154 · NVD
- FIRST EPSS
- GHSA-wm74-7g5x-vq4x · GitHub Advisory Database · CC BY 4.0
- CVE-2022-1154 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences