Use after free in kernel
Priority LOW 25CWE-416Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-416 and the CVSS impact.
Summary
A use-after-free vulnerabilitity was discovered in drivers/net/hamradio/6pack.c of linux that allows an attacker to crash linux kernel by simulating ax25 device using 6pack driver from user space.
Why it matters now
EPSS 0.00435 38th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | kernel | Fixed in kernel v5.17-rc6 | — | No fix listed | CNA |
- kernel Vendor— Affected Fixed in kernel v5.17-rc6 Fixed in — No fix listed CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 5.17 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* | 5.17 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* | 5.17 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* | 5.17 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc4:*:*:*:*:*:* | 5.17 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.17:rc5:*:*:*:*:*:* | 5.17 rc5 | Vulnerable | Linux |
| cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Red Hat |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 5.17 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc1:*:*:*:*:*:* Versions 5.17 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc2:*:*:*:*:*:* Versions 5.17 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc3:*:*:*:*:*:* Versions 5.17 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc4:*:*:*:*:*:* Versions 5.17 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.17:rc5:*:*:*:*:*:* Versions 5.17 rc5 Vulnerable ·Linux
- cpe:2.3:o:redhat:enterprise_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Red Hat
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1198
- 2026-10-03 Alias added: GHSA-p4xr-65m7-ff65
References
Sources
- CVE-2022-1198 · CVE Program
- CVE-2022-1198 · NVD
- FIRST EPSS
- GHSA-p4xr-65m7-ff65 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-1198 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences