HubSpot < 8.8.15 - Contributor+ Blind SSRF
Priority MEDIUM 41CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The HubSpot WordPress plugin before 8.8.15 does not validate the proxy URL given to the proxy REST endpoint, which could allow users with the edit_posts capability (by default contributor and above) to perform SSRF attacks
Why it matters now
EPSS 0.01417 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed HubSpot – CRM, Email Marketing, Live Chat, Forms & Analytics (Unknown): 8.8.15
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | HubSpot – CRM, Email Marketing, Live Chat, Forms & Analytics | 8.8.15 to before 8.8.15 | 8.8.15 | Patch available | CNA |
- HubSpot – CRM, Email Marketing, Live Chat, Forms & Analytics VendorUnknown Affected 8.8.15 to before 8.8.15 Fixed in 8.8.15 Patch available CNA
Remediation
- Fix · CNA HubSpot – CRM, Email Marketing, Live Chat, Forms & Analytics (Unknown) Fixed in 8.8.15
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1239
- 2026-10-03 Alias added: GHSA-mqqr-fmxw-ghxx
References
More Hubspot vulnerabilities
- TI-2024-05452 Cross-site scripting in hubspotdev HubSpot All-In-One Marketing – Forms, Popups, Live Chat CVSS 3.1MEDIUM 6.4
Sources
- CVE-2022-1239 · CVE Program
- CVE-2022-1239 · NVD
- FIRST EPSS
- GHSA-mqqr-fmxw-ghxx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences