VikBooking Hotel Booking Engine & PMS < 1.5.8 - Admin+ PHP File Upload
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-434.
Summary
The VikBooking Hotel Booking Engine & PMS WordPress plugin before 1.5.8 does not properly validate images, allowing high privilege users such as administrators to upload PHP files disguised as images and containing malicious PHP code
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | VikBooking Hotel Booking Engine & PMS | 1.5.8 to before 1.5.8 | 1.5.8 | Patch available | CNA |
- VikBooking Hotel Booking Engine & PMS VendorUnknown Affected 1.5.8 to before 1.5.8 Fixed in 1.5.8 Patch available CNA
Remediation
- Fix · CNA VikBooking Hotel Booking Engine & PMS (Unknown) Fixed in 1.5.8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
VikBooking Hotel Booking Engine & PMS 1.5.8
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-01288 VikBooking Hotel Booking Engine & PMS < 1.5.7 - Stored Cross-Site Scripting via CSRFPriority LOW 30
- TI-2022-01289 VikBooking Hotel Booking Engine & PMS < 1.5.8 - Admin+ Stored Cross-Site ScriptingPriority LOW 23
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1409
- 2026-10-03 Alias added: GHSA-wjwh-xprm-35wv
References
More Vikwp Hotel Booking Engine & Pms vulnerabilities
- TI-2022-01288 VikBooking Hotel Booking Engine & PMS < 1.5.7 - Stored Cross-Site Scripting via CSRF CVSS 3.1MEDIUM 6.5
- TI-2022-01289 VikBooking Hotel Booking Engine & PMS < 1.5.8 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-1409 · CVE Program
- CVE-2022-1409 · NVD
- FIRST EPSS
- GHSA-wjwh-xprm-35wv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences