Cross-site scripting in GitLab
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
An issue has been discovered in GitLab affecting all versions starting from 14.4 before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. Missing invalidation of Markdown caching causes potential payloads from a previously exploitable XSS vulnerability (CVE-2022-1175) to persist and execute.
Why it matters now
EPSS 0.00864 58th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.8.6, 14.9.4, 14.10.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 14.4 to before 14.8.6; 14.9 to before 14.9.4; 14.10 to before 14.10.1 | 14.8.6, 14.9.4, 14.10.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 14.4 to before 14.8.6; 14.9 to before 14.9.4; 14.10 to before 14.10.1 Fixed in 14.8.6, 14.9.4, 14.10.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.4.0 to before 14.8.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.4.0 to before 14.8.6 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.9.0 to before 14.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.9.0 to before 14.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:community:*:*:* | 14.10.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:enterprise:*:*:* | 14.10.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.4.0 to before 14.8.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.4.0 to before 14.8.6 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.9.0 to before 14.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.9.0 to before 14.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:community:*:*:* Versions 14.10.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:enterprise:*:*:* Versions 14.10.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 14.8.6, 14.9.4, 14.10.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1433
- 2026-10-03 Alias added: GHSA-jh26-hqr4-2cjg
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-1433 · CVE Program
- CVE-2022-1433 · NVD
- FIRST EPSS
- GHSA-jh26-hqr4-2cjg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences