Read the docs
TI-2022-01334 Aliases CVE-2022-1460GHSA-q7pq-xhw5-p4xw

Incorrect authorization in GitLab

Priority LOW 30CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.

Summary

An issue has been discovered in GitLab affecting all versions starting from 9.2 before 14.8.6, all versions starting from 14.9 before 14.9.4, all versions starting from 14.10 before 14.10.1. GitLab was not performing correct authorizations on scheduled pipelines allowing a malicious user to run a pipeline in the context of another user.

Why it matters now

EPSS 0.01195 68th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.8.6, 14.9.4, 14.10.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitLabGitLab9.2 to before 14.8.6; 14.9 to before 14.9.4; 14.10 to before 14.10.114.8.6, 14.9.4, 14.10.1Patch availableCNA
  • GitLab VendorGitLab Affected 9.2 to before 14.8.6; 14.9 to before 14.9.4; 14.10 to before 14.10.1 Fixed in 14.8.6, 14.9.4, 14.10.1 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*9.2.0 to before 14.8.6VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*9.2.0 to before 14.8.6VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*14.9.0 to before 14.9.4VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*14.9.0 to before 14.9.4VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:community:*:*:*14.10.0VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:enterprise:*:*:*14.10.0VulnerableGitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 9.2.0 to before 14.8.6 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 9.2.0 to before 14.8.6 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.9.0 to before 14.9.4 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.9.0 to before 14.9.4 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:community:*:*:* Versions 14.10.0 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:14.10.0:*:*:*:enterprise:*:*:* Versions 14.10.0 Vulnerable ·GitLab

Remediation

  • Fix · CNA GitLab (GitLab) Fixed in 14.8.6, 14.9.4, 14.10.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1460
  2. 2026-10-03 Alias added: GHSA-q7pq-xhw5-p4xw

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
See all 1506 →

Sources