Read the docs
TI-2022-01348 Aliases CVE-2022-1474GHSA-9hx4-3rxw-768x

WP Event Manager < 3.1.28 - Reflected Cross-Site Scripting

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Event Manager WordPress plugin before 3.1.28 does not sanitise and escape its search before outputting it back in an attribute on the event dashboard, leading to a Reflected Cross-Site Scripting

Why it matters now

EPSS 0.00849 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Event Manager – Easily Build your Calendar of Events! (Unknown): 3.1.28

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Event Manager – Easily Build your Calendar of Events!3.1.28 to before 3.1.283.1.28Patch availableCNA
  • WP Event Manager – Easily Build your Calendar of Events! VendorUnknown Affected 3.1.28 to before 3.1.28 Fixed in 3.1.28 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wp-eventmanager:wp_event_manager:*:*:*:*:*:wordpress:*:*before 3.1.28VulnerableWP Event Manager
  • cpe:2.3:a:wp-eventmanager:wp_event_manager:*:*:*:*:*:wordpress:*:* Versions before 3.1.28 Vulnerable ·WP Event Manager

Remediation

  • Fix · CNA WP Event Manager – Easily Build your Calendar of Events! (Unknown) Fixed in 3.1.28

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1474
  2. 2026-10-03 Alias added: GHSA-9hx4-3rxw-768x

References

  • TI-2025-02444 WP Event Manager <= 3.1.50 - Unauthenticated Stored Cross-Site Scripting via 'organizer_name' CVSS 3.1HIGH 7.2
  • TI-2023-25834 WordPress WP Event Manager Plugin <= 3.1.39 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-28557 WordPress WP User Profile Avatar Plugin <= 1.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2024-02506 Cross-site scripting in WP Event Manager – Events Calendar, Registrations, Sell Tickets… CVSS 3.1MEDIUM 6.4
  • TI-2024-00900 WP Event Manager <= 3.1.41 - Reflected Cross-Site Scripting via plugin CVSS 3.1MEDIUM 6.1
  • TI-2023-26840 WordPress WP Event Manager Plugin <= 3.1.40 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
See all 9 →

Sources