Command Injection Vulnerability in hestiacp/hestiacp
Priority MEDIUM 50CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
Command Injection Vulnerability in GitHub repository hestiacp/hestiacp prior to 1.5.12. An authenticated remote attacker with low privileges can execute arbitrary code under root context.
Why it matters now
EPSS 0.04532 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed hestiacp/hestiacp (hestiacp): 1.5.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA hestiacp/hestiacp (hestiacp) Fixed in 1.5.12
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1509
- 2026-10-03 Alias added: GHSA-99wp-pqm6-2vh4
References
More hestiacp Control Panel vulnerabilities
- TI-2023-05375 Privilege Chaining in hestiacp/hestiacp CVSS 3.1HIGH 7.8
- TI-2022-02355 OS Command Injection in hestiacp/hestiacp CVSS 3.1HIGH 8.8
- TI-2023-03249 Cross-site Scripting (XSS) - Reflected in hestiacp/hestiacp CVSS 3.1MEDIUM 6.1
- TI-2025-21382 HestiaCP < 1.9.5 Authenticated OS Command Injection via DNS Record Management CVSS 4.0HIGH 8.7
- TI-2021-02728 Use of Wrong Operator in String Comparison in hestiacp/hestiacp CVSS 3.1CRITICAL 9.8
- TI-2022-02437 Code Injection in hestiacp/hestiacp CVSS 3.1HIGH 8.8
Sources
- CVE-2022-1509 · CVE Program
- CVE-2022-1509 · NVD
- FIRST EPSS
- GHSA-99wp-pqm6-2vh4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences