Read the docs
TI-2022-01434 Aliases CVE-2022-1563GHSA-c5j7-mp6j-v4wc

WPGraphQL WooCommerce <= 0.11.0 - Unauthenticated Coupon Codes Disclosure

Priority MEDIUM 63Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The WPGraphQL WooCommerce WordPress plugin before 0.12.4 does not prevent unauthenticated attackers from enumerating a shop's coupon codes and values via GraphQL.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00724 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed wp-graphql-woocommerce (Unknown): 0.12.4

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Unknownwp-graphql-woocommercebefore 0.12.40.12.4Patch availableCNA
  • wp-graphql-woocommerce VendorUnknown Affected before 0.12.4 Fixed in 0.12.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpengine:wpgraphql:*:*:*:*:*:wordpress:*:*up to 0.12.3Vulnerablewpengine
  • cpe:2.3:a:wpengine:wpgraphql:*:*:*:*:*:wordpress:*:* Versions up to 0.12.3 Vulnerable ·wpengine

Remediation

  • Fix · CNA wp-graphql-woocommerce (Unknown) Fixed in 0.12.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1563
  2. 2026-10-03 Alias added: GHSA-c5j7-mp6j-v4wc

References

  • TI-2019-07258 The WPGraphQL 0.2.3 plugin for WordPress allows remote attackers to register a new user… CVSS 3.0CRITICAL 9.8
  • TI-2019-07259 An issue was discovered in the WPGraphQL 0.2.3 plugin for WordPress. CVSS 3.0CRITICAL 9.1
  • TI-2019-07260 The createComment mutation in the WPGraphQL 0.2.3 plugin for WordPress allows… CVSS 3.0MEDIUM 5.3
  • TI-2023-09498 WordPress WPGraphQL Plugin <= 1.14.5 is vulnerable to Server Side Request Forgery (SSRF) CVSS 3.1MEDIUM 6.5

Sources