WP-Email < 2.69.0 - Anti-Spam Protection Bypass via IP Spoofing
Priority LOW 35CWE-639Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-639.
Summary
The WP-EMail WordPress plugin before 2.69.0 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based anti-spamming restrictions.
Why it matters now
EPSS 0.01178 67th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP-EMail (Unknown): 2.69.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP-EMail | 2.69.0 to before 2.69.0 | 2.69.0 | Patch available | CNA |
- WP-EMail VendorUnknown Affected 2.69.0 to before 2.69.0 Fixed in 2.69.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-email_project:wp-email:*:*:*:*:*:wordpress:*:* | before 2.69.0 | Vulnerable | Wp-email Project |
- cpe:2.3:a:wp-email_project:wp-email:*:*:*:*:*:wordpress:*:* Versions before 2.69.0 Vulnerable ·Wp-email Project
Remediation
- Fix · CNA WP-EMail (Unknown) Fixed in 2.69.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WP-EMail 2.69.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-01500 WP-Email < 2.69.0 - Log Deletion via CSRFPriority LOW 30
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1614
- 2026-10-03 Alias added: GHSA-m7mv-qpw5-vp4f
References
More Wp-email Project Wp-email vulnerabilities
- TI-2022-01500 WP-Email < 2.69.0 - Log Deletion via CSRF CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-1614 · CVE Program
- CVE-2022-1614 · NVD
- FIRST EPSS
- GHSA-m7mv-qpw5-vp4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences