Insights from Google PageSpeed < 4.0.7 - Multiple CSRF
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The Insights from Google PageSpeed WordPress plugin before 4.0.7 does not verify for CSRF before doing various actions such as deleting Custom URLs, which could allow attackers to make a logged in admin perform such actions via CSRF attacks
Why it matters now
EPSS 0.00602 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Insights from Google PageSpeed (Unknown): 4.0.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Insights from Google PageSpeed | 4.0.7 to before 4.0.7 | 4.0.7 | Patch available | CNA |
- Insights from Google PageSpeed VendorUnknown Affected 4.0.7 to before 4.0.7 Fixed in 4.0.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:insights_from_google_pagespeed_project:insights_from_google_pagespeed:*:*:*:*:*:wordpress:*:* | before 4.0.7 | Vulnerable | Insights From Google Pagespeed Project |
- cpe:2.3:a:insights_from_google_pagespeed_project:insights_from_google_pagespeed:*:*:*:*:*:wordpress:*:* Versions before 4.0.7 Vulnerable ·Insights From Google Pagespeed Project
Remediation
- Fix · CNA Insights from Google PageSpeed (Unknown) Fixed in 4.0.7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1672
- 2026-10-03 Alias added: GHSA-28mj-h58q-vmmm
References
More Insights From Google Pagespeed Project Insights From Google Pagespeed vulnerabilities
- TI-2022-00355 Google Pagespeed Insights < 4.0.4 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-1672 · CVE Program
- CVE-2022-1672 · NVD
- FIRST EPSS
- GHSA-28mj-h58q-vmmm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences