Cross-site scripting in wenzhixin/bootstrap-table
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Bootstrap Tables XSS vulnerability with Table Export plug-in when exportOptions: htmlContent is true in GitHub repository wenzhixin/bootstrap-table prior to 1.20.2. Disclosing session cookies, disclosing secure session data, exfiltrating data to third-parties.
Why it matters now
EPSS 0.00889 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed wenzhixin/bootstrap-table (wenzhixin): 1.20.2bootstrap-table (npm): 1.20.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wenzhixin | wenzhixin/bootstrap-table | before 1.20.2 | 1.20.2 | Patch available | CNA |
| — | bootstrap-table (npm) | before 1.20.2 | 1.20.2 | Patch available | GHSA-grw5-g9h2-wpg8 |
- wenzhixin/bootstrap-table Vendorwenzhixin Affected before 1.20.2 Fixed in 1.20.2 Patch available CNA
- bootstrap-table (npm) Vendor— Affected before 1.20.2 Fixed in 1.20.2 Patch available GHSA-grw5-g9h2-wpg8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:bootstrap-table:bootstrap_table:*:*:*:*:*:*:*:* | before 1.20.2 | Vulnerable | Bootstrap-table |
- cpe:2.3:a:bootstrap-table:bootstrap_table:*:*:*:*:*:*:*:* Versions before 1.20.2 Vulnerable ·Bootstrap-table
Remediation
- Fix · CNA wenzhixin/bootstrap-table (wenzhixin) Fixed in 1.20.2
- Fix · GHSA-grw5-g9h2-wpg8 bootstrap-table (npm) Fixed in 1.20.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1726
- 2026-10-03 Alias added: GHSA-grw5-g9h2-wpg8
References
More Bootstrap-table Bootstrap Table vulnerabilities
- TI-2021-06147 Cross-site scripting (XSS) in bootstrap-table CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-1726 · CVE Program
- CVE-2022-1726 · NVD
- FIRST EPSS
- GHSA-grw5-g9h2-wpg8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences