Heap-based Buffer Overflow in vim/vim
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-122 and the CVSS impact.
Summary
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 8.2.4968.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2.4968 | 8.2.4968 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2.4968 Fixed in 8.2.4968 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 8.2.4968 | Vulnerable | vim |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | before 13.0 | Vulnerable | Apple |
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 8.2.4968 Vulnerable ·vim
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions before 13.0 Vulnerable ·Apple
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2.4968
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
vim/vim — FEDORA-2022-d044e7e0b4
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-01635 Buffer Over-read in vim/vimPriority LOW 34
- TI-2022-01544 NULL Pointer Dereference in function vim_regexec_string at regexp.c:2733 in vim/vimPriority LOW 28
- Advisory ·
vim/vim — FEDORA-2022-74b9e404c1
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-01635 Buffer Over-read in vim/vimPriority LOW 34
- TI-2022-01544 NULL Pointer Dereference in function vim_regexec_string at regexp.c:2733 in vim/vimPriority LOW 28
Show 1 more group
- Advisory ·
vim/vim — FEDORA-2022-d6d1ac4ca7
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-01635 Buffer Over-read in vim/vimPriority LOW 34
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1733
- 2026-10-03 Alias added: GHSA-x282-2jwx-hvgg
References
Advisory 7
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2022-1733 · CVE Program
- CVE-2022-1733 · NVD
- FIRST EPSS
- GHSA-x282-2jwx-hvgg · GitHub Advisory Database · CC BY 4.0
- CVE-2022-1733 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences