Pagebar < 2.70 - Arbitrary Settings Update via CSRF to Stored XSS
Priority LOW 24CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-79.
Summary
The pagebar WordPress plugin before 2.70 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack. Furthermore, due to the lack of sanitisation in some of them, it could also lead to Stored XSS issues
Why it matters now
EPSS 0.00344 28th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pagebar (Unknown): 2.70
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | pagebar | 2.70 to before 2.70 | 2.70 | Patch available | CNA |
- pagebar VendorUnknown Affected 2.70 to before 2.70 Fixed in 2.70 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pagebar_project:pagebar:*:*:*:*:*:wordpress:*:* | before 2.70 | Vulnerable | Pagebar Project |
- cpe:2.3:a:pagebar_project:pagebar:*:*:*:*:*:wordpress:*:* Versions before 2.70 Vulnerable ·Pagebar Project
Remediation
- Fix · CNA pagebar (Unknown) Fixed in 2.70
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1757
- 2026-10-03 Alias added: GHSA-r4g8-72wp-fwqg
References
Sources
- CVE-2022-1757 · CVE Program
- CVE-2022-1757 · NVD
- FIRST EPSS
- GHSA-r4g8-72wp-fwqg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences