An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.3…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An issue has been discovered in GitLab CE/EE affecting all versions starting from 14.3 before 14.9.5, all versions starting from 14.10 before 14.10.4, all versions starting from 15.0 before 15.0.1. It may be possible for malicious group maintainers to add new members to a project within their group, through the REST API, even after their group owner enabled a setting to prevent members from being added to projects within that group.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 15.0.0 to before 15.0.1; 14.10.0 to before 14.10.4; 14.3 to before 14.9.5 | 15.0.1, 14.10.4, 14.9.5 | Patch available | CNA |
- GitLab VendorGitLab Affected 15.0.0 to before 15.0.1; 14.10.0 to before 14.10.4; 14.3 to before 14.9.5 Fixed in 15.0.1, 14.10.4, 14.9.5 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.3.0 to before 14.9.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.3.0 to before 14.9.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 14.10.0 to before 14.10.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 14.10.0 to before 14.10.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:community:*:*:* | 15.0.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:enterprise:*:*:* | 15.0.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.3.0 to before 14.9.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.3.0 to before 14.9.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.10.0 to before 14.10.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.10.0 to before 14.10.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:community:*:*:* Versions 15.0.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:enterprise:*:*:* Versions 15.0.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.0.1, 14.10.4, 14.9.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1783
- 2026-10-03 Alias added: GHSA-gqc9-9f54-xc45
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2022-1783 · CVE Program
- CVE-2022-1783 · NVD
- FIRST EPSS
- GHSA-gqc9-9f54-xc45 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences