Out-of-bounds Write in vim/vim
Priority LOW 35CWE-787Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
Out-of-bounds Write in GitHub repository vim/vim prior to 8.2.4977.
Why it matters now
EPSS 0.00494 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vim/vim (vim): 8.2.4977Red Hat: 2 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 8.2.4977 | 8.2.4977 | Patch available | CNA |
- vim/vim Vendorvim Affected before 8.2.4977 Fixed in 8.2.4977 Patch available CNA
Remediation
- Fix · CNA vim/vim (vim) Fixed in 8.2.4977
Red Hat 2 advisories
- RHSA-2022:5942 Released 2022-08-09 · Red Hat rating Moderatevim security update
- Red Hat Enterprise Linux AppStream (v. 9) vim-X11-2:8.2.2637-16.el9_0.3, vim-common-2:8.2.2637-16.el9_0.3, vim-enhanced-2:8.2.2637-16.el9_0.3
- Red Hat Enterprise Linux BaseOS (v. 9) vim-2:8.2.2637-16.el9_0.3, vim-filesystem-2:8.2.2637-16.el9_0.3, vim-minimal-2:8.2.2637-16.el9_0.3
- RHSA-2022:5813 Released 2022-08-03 · Red Hat rating Moderatevim security update
- Red Hat Enterprise Linux AppStream (v. 8) vim-X11-2:8.0.1763-19.el8_6.4, vim-common-2:8.0.1763-19.el8_6.4, vim-enhanced-2:8.0.1763-19.el8_6.4 +1
- Red Hat Enterprise Linux BaseOS (v. 8) vim-2:8.0.1763-19.el8_6.4, vim-minimal-2:8.0.1763-19.el8_6.4
- Red Hat Virtualization 4 Hypervisor for RHEL 8 vim-2:8.0.1763-19.el8_6.4, vim-minimal-2:8.0.1763-19.el8_6.4
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2022:5813 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:5942 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2022:5813 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2022:5942 |
| Red Hat Virtualization 4 Hypervisor for RHEL 8 | Fixed | RHSA-2022:5813 |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1785
- 2026-10-03 Alias added: GHSA-c8gc-wmr9-fq4m
References
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2022-1785 · CVE Program
- CVE-2022-1785 · NVD
- FIRST EPSS
- GHSA-c8gc-wmr9-fq4m · GitHub Advisory Database · CC BY 4.0
- CVE-2022-1785 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences