Accountsservice incorrectly drops privileges
Priority LOW 24CWE-269Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-269.
Summary
accountsservice no longer drops permissions when writting .pam_environment
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00141 3rd percentileScored 2026-11-07
Fix Fixed Linux (Ubuntu): 22.07.5-2ubuntu1.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ubuntu | Linux | 0.6.55-3ubuntu1 to before 22.07.5-2ubuntu1.3 | 22.07.5-2ubuntu1.3 | Patch available | CNA |
- Linux VendorUbuntu Affected 0.6.55-3ubuntu1 to before 22.07.5-2ubuntu1.3 Fixed in 22.07.5-2ubuntu1.3 Patch available CNA
Remediation
- Fix · CNA Linux (Ubuntu) Fixed in 22.07.5-2ubuntu1.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1804
- 2026-10-03 Alias added: GHSA-v7v5-m765-h4w4
References
More Ubuntu vulnerabilities
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2007-05153 Stack-based buffer overflow in the cons_options function in options.c in dhcpd in OpenBSD… CVSS 2.0HIGH 7.2
- TI-2004-01032 Multiple vulnerabilities in the IGMP functionality for Linux kernel 2.4.22 to 2.4.28, and… CVSS 2.0HIGH 10.0
- TI-2004-00896 Multiple buffer overflows in libXML 2.6.12 and 2.6.13 (libxml2), and possibly other… CVSS 2.0HIGH 10.0
- TI-2004-00800 Buffer overflow in the QFILEPATHINFO request handler in Samba 3.0.x through 3.0.7 may… CVSS 2.0HIGH 10.0
- TI-2004-00962 Buffer overflow in the exif_read_data function in PHP before 4.3.10 and PHP 5.x up to… CVSS 2.0HIGH 10.0
Sources
- CVE-2022-1804 · CVE Program
- CVE-2022-1804 · NVD
- FIRST EPSS
- GHSA-v7v5-m765-h4w4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences