Exponential ReDoS in devcert
Priority LOW 34CWE-1333Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-1333.
Summary
An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the devcert npm package, when an attacker is able to supply arbitrary input to the certificateFor method
Why it matters now
EPSS 0.00641 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed devcert (devcert): 1.2.1devcert (npm): 1.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| devcert | devcert | before 1.2.1 | 1.2.1 | Patch available | CNA |
| — | devcert (npm) | before 1.2.1 | 1.2.1 | Patch available | GHSA-fp36-299x-pwmw |
- devcert Vendordevcert Affected before 1.2.1 Fixed in 1.2.1 Patch available CNA
- devcert (npm) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-fp36-299x-pwmw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:devcert_project:devcert:*:*:*:*:*:node.js:*:* | before 1.2.1 | Vulnerable | Devcert Project |
- cpe:2.3:a:devcert_project:devcert:*:*:*:*:*:node.js:*:* Versions before 1.2.1 Vulnerable ·Devcert Project
Remediation
- Fix · CNA devcert (devcert) Fixed in 1.2.1
- Fix · GHSA-fp36-299x-pwmw devcert (npm) Fixed in 1.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1929
- 2026-10-03 Alias added: GHSA-fp36-299x-pwmw
- 2026-10-21 EPSS moved to the 50th–90th percentile
References
More Devcert Project Devcert vulnerabilities
- TI-2020-06604 Command injection in devcert CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-1929 · CVE Program
- CVE-2022-1929 · NVD
- FIRST EPSS
- GHSA-fp36-299x-pwmw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences