Read the docs
TI-2022-01803 Aliases CVE-2022-1944GHSA-2wrv-52w9-gffw

Incorrect authorization in GitLab

Priority LOW 32CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.

Summary

When the feature is configured, improper authorization in the Interactive Web Terminal in GitLab CE/EE affecting all versions from 11.3 prior to 14.9.5, 14.10 prior to 14.10.4, and 15.0 prior to 15.0.1 allows users with the Developer role to open terminals on other Developers' running jobs

Why it matters now

EPSS 0.00572 47th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 14.9.5, 14.10.4, 15.0.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
GitLabGitLab11.3 to before 14.9.5; 14.10 to before 14.10.4; 15.0 to before 15.0.114.9.5, 14.10.4, 15.0.1Patch availableCNA
  • GitLab VendorGitLab Affected 11.3 to before 14.9.5; 14.10 to before 14.10.4; 15.0 to before 15.0.1 Fixed in 14.9.5, 14.10.4, 15.0.1 Patch available CNA

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*11.3.0 to before 14.9.5VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*11.3.0 to before 14.9.5VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*14.10.0 to before 14.10.4VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*14.10.0 to before 14.10.4VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:community:*:*:*15.0.0VulnerableGitLab
cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:enterprise:*:*:*15.0.0VulnerableGitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 11.3.0 to before 14.9.5 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 11.3.0 to before 14.9.5 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 14.10.0 to before 14.10.4 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 14.10.0 to before 14.10.4 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:community:*:*:* Versions 15.0.0 Vulnerable ·GitLab
  • cpe:2.3:a:gitlab:gitlab:15.0.0:*:*:*:enterprise:*:*:* Versions 15.0.0 Vulnerable ·GitLab

Remediation

  • Fix · CNA GitLab (GitLab) Fixed in 14.9.5, 14.10.4, 15.0.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1944
  2. 2026-10-03 Alias added: GHSA-2wrv-52w9-gffw

References

  • TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
  • TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
  • TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
  • TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
See all 1506 →

Sources