Read the docs
TI-2022-01810 Aliases CVE-2022-1951GHSA-m3jq-mhq5-xpc9

Core Plugin for Kitestudio Themes < 2.3.1 - Reflected Cross-Site-Scripting

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The core plugin for kitestudio WordPress plugin before 2.3.1 does not sanitise and escape some parameters before outputting them back in a response of an AJAX action, available to both unauthenticated and authenticated users when a premium theme from the vendor is active, leading to a Reflected Cross-Site Scripting.

Why it matters now

EPSS 0.00783 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed core plugin for kitestudio themes (Unknown): 2.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Unknowncore plugin for kitestudio themes2.3.1 to before 2.3.12.3.1Patch availableCNA
  • core plugin for kitestudio themes VendorUnknown Affected 2.3.1 to before 2.3.1 Fixed in 2.3.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:kitestudio:core_plugin_for_kitestudio_themes:*:*:*:*:*:wordpress:*:*before 2.3.1VulnerableKitestudio
  • cpe:2.3:a:kitestudio:core_plugin_for_kitestudio_themes:*:*:*:*:*:wordpress:*:* Versions before 2.3.1 Vulnerable ·Kitestudio

Remediation

  • Fix · CNA core plugin for kitestudio themes (Unknown) Fixed in 2.3.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-1951
  2. 2026-10-03 Alias added: GHSA-m3jq-mhq5-xpc9

References

Sources