Product Configurator for WooCommerce < 1.2.32 - Unauthenticated Arbitrary File Deletion
Priority MEDIUM 43CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Product Configurator for WooCommerce WordPress plugin before 1.2.32 suffers from an arbitrary file deletion vulnerability via an AJAX action, accessible to unauthenticated users, which accepts user input that is being used in a path and passed to unlink() without validation first
Why it matters now
EPSS 0.01717 77th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Product Configurator for WooCommerce (Unknown): 1.2.32
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Product Configurator for WooCommerce | 1.2.32 to before 1.2.32 | 1.2.32 | Patch available | CNA |
- Product Configurator for WooCommerce VendorUnknown Affected 1.2.32 to before 1.2.32 Fixed in 1.2.32 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:product_configurator_for_woocommerce_project:product_configurator_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 1.2.32 | Vulnerable | Product Configurator For Woocommerce Project |
- cpe:2.3:a:product_configurator_for_woocommerce_project:product_configurator_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 1.2.32 Vulnerable ·Product Configurator For Woocommerce Project
Remediation
- Fix · CNA Product Configurator for WooCommerce (Unknown) Fixed in 1.2.32
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1953
- 2026-10-03 Alias added: GHSA-6qhx-qfq2-78g9
References
Sources
- CVE-2022-1953 · CVE Program
- CVE-2022-1953 · NVD
- FIRST EPSS
- GHSA-6qhx-qfq2-78g9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences