Comment License < 1.4.0 - Arbitrary Settings Update via CSRF
Priority LOW 20CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The Comment License WordPress plugin before 1.4.0 does not have CSRF check in place when updating its settings, which could allow attackers to make a logged in admin change them via a CSRF attack
Why it matters now
EPSS 0.00429 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Comment License (Unknown): 1.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Comment License | 1.4.0 to before 1.4.0 | 1.4.0 | Patch available | CNA |
- Comment License VendorUnknown Affected 1.4.0 to before 1.4.0 Fixed in 1.4.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:comment_license_project:comment_license:*:*:*:*:*:wordpress:*:* | before 1.4.0 | Vulnerable | Comment License Project |
- cpe:2.3:a:comment_license_project:comment_license:*:*:*:*:*:wordpress:*:* Versions before 1.4.0 Vulnerable ·Comment License Project
Remediation
- Fix · CNA Comment License (Unknown) Fixed in 1.4.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1957
- 2026-10-03 Alias added: GHSA-rc6g-9fhg-5f9j
References
Sources
- CVE-2022-1957 · CVE Program
- CVE-2022-1957 · NVD
- FIRST EPSS
- GHSA-rc6g-9fhg-5f9j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences