CODESYS runtime system prone to file deletion due to improper error handling
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Multiple products of CODESYS implement a improper error handling. A low privilege remote attacker may craft a request, which is not properly processed by the error handling. In consequence, the file referenced by the request could be deleted. User interaction is not required.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| CODESYS | Runtime Toolkit | V2 to before V2.4.7.57 | V2.4.7.57 | Patch available | CNA |
| CODESYS | PLCWinNT | V2 to before V2.4.7.57 | V2.4.7.57 | Patch available | CNA |
Remediation
- Fix · CNA Runtime Toolkit (CODESYS) Fixed in V2.4.7.57
- Fix · CNA PLCWinNT (CODESYS) Fixed in V2.4.7.57
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
CODESYS PLCWinNT, Runtime Toolkit V2.4.7.57
9 records Highest priority Priority MEDIUM 3 MEDIUM, 6 LOW
Other records, highest priority first
- TI-2022-13872 CODESYS Runtime System prone to heap based buffer overflowPriority MEDIUM 41
- TI-2022-13878 CODESYS runtime system prone to directory accesPriority MEDIUM 40
- TI-2022-13873 CODESYS runtime system prone to denial of service due to Unexpected Sign ExtensionPriority MEDIUM 40
Timeline
- 2026-10-02 Threatist record created from CVE-2022-1965
- 2026-10-03 Alias added: GHSA-xw5j-8gp6-p2vj
References
More CODESYS Plcwinnt vulnerabilities
- TI-2022-13698 Insecure default settings in CODESYS Runtime Toolkit 32 bit full and CODESYS PLCWinNT CVSS 3.1CRITICAL 9.8
- TI-2021-10734 CODESYS V2 runtime system before 2.4.7.55 has Improper Input Validation. CVSS 3.1HIGH 7.5
- TI-2021-10725 CODESYS V2 runtime system SP before 2.4.7.55 has a Heap-based Buffer Overflow. CVSS 3.1HIGH 7.5
- TI-2022-13872 CODESYS Runtime System prone to heap based buffer overflow CVSS 3.1HIGH 8.8
- TI-2022-13878 CODESYS runtime system prone to directory acces CVSS 3.1HIGH 8.8
- TI-2022-13873 CODESYS runtime system prone to denial of service due to Unexpected Sign Extension CVSS 3.1HIGH 8.8
Sources
- CVE-2022-1965 · CVE Program
- CVE-2022-1965 · NVD
- FIRST EPSS
- GHSA-xw5j-8gp6-p2vj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences